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The License Renewal Comparison Tool requires the following input files:

e One or more license server inventory file or files ( *.txt ) generated by the
getOrderNumbers tool.
e Portal download file of already renewed licenses (Renewed- *-date. csv)

Optionally, you can load the portal download file of still to be renewed licenses (To- Be- Renewed- *-

date. csv).

The comparison tool processes these files against the data in the Product Number Key tab. This

data is provided with the yearly updated version of the tool (see How to install and start the

Comparison Tool).

License server inventory .txt files

In most cases you will have a single license server inventory file (getOrderNumbers output file).

This is the case if your licensing setup consists of a single FLEXIm license server, if it is a three-
license-server redundancy configuration, or for multiple independent license servers in a network.
For these configurations you will have one license server inventory file showing the installed
licenses for all license servers.

Only in case of multiple license servers in independent networks you will have one license server

inventory file per network. In this case you must run the getOrderNumbers tool on a server in each

network.

You must use a .txt file name extension for each file, for example |icense-inventory-server01.txt.


https://lhc.advantest.com/link/104#bkmrk-how-to-restart-and-r-1
https://lhc.advantest.com/link/104#bkmrk-how-to-filter-licens
https://lhc.advantest.com/link/104#bkmrk-how-to-view-and-sort
https://lhc.advantest.com/link/104#bkmrk-how-to-save-resultin
https://lhc.advantest.com/link/104#bkmrk-how-to-view-and-save
https://lhc.advantest.com/books/fnp-license-renewal/page/installing-and-updating-the-comparison-tool
https://lhc.advantest.com/books/fnp-license-renewal/page/installing-and-updating-the-comparison-tool
https://lhc.advantest.com/books/fnp-license-renewal/page/getordernumbers-tool

Renewed-*-date.csv files

You must visit the License Renewal Portal before running the Comparison Tool. The portal allows
you to download a record file which lists the already renewed licenses (Renewed-*-date. csv).

To-Be-Renewed-*-date.csv files

The License Renewal Portal also allows you to download record file of still to be renewed licenses (
To- Be- Renewed- *- dat e. csv). This file as it provides insight, in case the renewal process does not run
as smooth as expected.

Collect in single directory

The License Renewal Portal writes both .csv record files into a Li cense. zi p file. For further
processing you need to extract them.

Advantest recommends to create a single directory or folder, for example verigy-1icense-renewal -
year, and collect all these files in this directory. If all input files are available in your local file
system, you can run the Comparison Tool stand-alone in off-line mode.

The directory of your collected input files may look as follows:

verigy-license-renewal-2009/license-inventory-server0l.txt

verigy-license-renewal-2009/Renewed-*-date.csv
verigy-license-renewal-2009/To-Be-Renewed-*-date.csv

Related information

Installing and updating the Comparison Tool

getOrderNumbers tool
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How to restart and reload
files

Restarting the comparison process or reloading files may be required when you have additional or
updated input data.

About this task

If you restart the process, you follow the prompts of the License Renewal Comparison Tool and
reload the files as requested. (See the procedure instructions below.)

You can also reload single files individually or load additional license server inventory files. In this
case click File > Open...and select the required files.

In both cases, once the last required file is loaded, the Comparison Tool automatically reprocesses
the currently loaded files and displays the result.

Before you begin

To restart the comparison process or to reload updated files, the Comparison Tool must be running
and you must have completed the comparison process at least once. Make sure you have the
additional or updated files available. If not, you cannot complete the task and the Comparison Tool
will close.

Procedure

1. To restart the comparison process, click File > Restart.
The Portal Export Available dialog appears and asks you to load the portal export file of
renewed licenses (Renewed- *- dat e. csv) .



2. If you have the required portal export file click Yes. The Select Renewal Portal Export File
dialog appears.

3. Navigate to the directory containing the portal export files, and double-click the Renewed- *-
date. csv file. The Comparison Tool's main window changes to two tabs and a dialog
prompts you to optionally load the portal export file of un-renewed and unassigned
licenses (To- Be- Renewed- *- date. csv).

4. If you have the To-Be-Renewed-*-date.csv file click Yes and load the file. If you Do not
have the file click No.

In both cases the next dialog appears and asks you to load your license server inventory
* txt files.

5. If you have the license server inventory *. txt files click Yes. A select dialog appears.

6. Click the *.txt file containing your license server inventory data (for example,
ny_licenses. txt)and Open. You can also press Shift or Ctrl and select multiple files to
load.

An additional tab opens in the Comparison Tool's main window and the Additional Server

Inventory Files? dialog appears.

7. If you have any additional license server inventory *. txt files click Yes and proceed as
before to load the files. If you have no additional files click No.

Results

The Comparison Tool's main window now shows up to seven tabs, and displays the Matched tab in
the foreground.

How to filter license data

Filtering allows you to reduce the amount of displayed license data.

About this task

To reduce the amount of displayed data you can filter the data either based on



customers,

license server host IDs,
order IDs,

product descriptions, or
license expiration dates.

To sharpen the focus even further you can also combine these filter parameters.

Before you begin

All required files must be loaded and the Comparison Tool must have completed the comparison
process.

Procedure

1. To filter based on product descriptions, for example, click Filter > Filter Using Product
Descriptions.
The filter dialog appears. On the left it shows the included items, on the left the excluded
items.

2. To move an individual parameter to the right to be excluded, click first the parameter
then click >. To move one to the left to be included, select it and click <.

3. To move all parameters to the right, click >>. To move all to the left, click <<.

4. To complete the filtering and close the dialog click OK.

Results

The selected filter parameters are applied and the Comparison Tool shows a reduced amount of
data in all tabs.

The filtering parameters will stay applied until you exit the tool or click Filter > No Filtering.

Example



Filter By License Server ProductDescription(s)

Included ProductDescriptionds) Excluded ProductDescription(s)
Fin Scale 300/3600 memory upgrade 16 ko 32MB, perpetual per pin floating license PinScale3600 Base Bundle Perpetual
Pin Scale 8003600 mermary upgrade 32 ko 64ME, perpetual per pin floating license Pin Scale SmarTest on-line SW, perpetual per session Floating license

Pin Scale 3600, upgrade 800Mbps ko 1.8Gbps, perpetual per pin Flaating i
Pin Scale 3600, upgrade 1.5Gbps to 3.6Gbps, perpetual per pin floating lic
> PFin Scale 3600, base capability, perpetual per board floating license
rultisite device power supply upgrade 4 - & channels, perpetual Floating lic
- Mulki-site DPS Sch Perpetual

Pin Scale 8003600 mermary upgrade 5 bo 16ME, perpetual per pin floating license

[ +— Cancel ” v Ok ]

How to view and sort data

Toggling between list and matrix views views plus sorting data columns allows you to improve
readability or display data according to your needs.

About this task

You can toggle the view of the tabs

e Renewed _in_Portal
e To Be Renewed in_Portal (if data loaded)
e License Server Output

Data columns can be sorted in list views that show the raw data without coloring. The current sort
column is marked by a green arrow, pointing either upwards (ascending) or downwards
(descending).

Colored matrix views are fixed and cannot be sorted. In this matrix view, you can display tool tips
with a product description for each product number.

Before you begin

You must have loaded all files and the tool must have completed the comparison before you can
toggle views or sort data.
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Procedure

e To toggle a view:

Right-click a supported tab and click Toggle ... View.
The tab switches either from a colored matrix view to a list view or vice versa.

e To sort a data column:
In a list view click any data column header. The whole table is rearranged based on the
alphanumerical sort order of this column. A green arrow indicates the sorted column.

The first click produces an ascending order, a second click produces a descending order.
The third click brings it it back to its original order.

e To display tool tips:

In a colored matrix view move the pointer over a product number in the header. The
appearing tooltip displays the more familiar product description.

Example



License Renewal Comparison Tool

Fie Fiter Help
" Matched £ Reneweed Entry, Without Server Entry £ Server_Entry_Withowt_Renewed_Entry
#4 Product Humber Key 01 Renewed_in_Portal 3 10-Be-Renewed_in_Portal & License_Server_Ouiput
License Serens) Entitlement
B ME A¥3 S8M: 2 cores 100 bo 200Msps AWG upgrads |
0011BB222222 |

License Renewal Comparison Tool

Fie Fiter Help

It +/ Matched 45 Reneseed Entrv WIthout Server Entry £ Server_Entry_Without_Renewed_Entry
#4 Product Humber Key K Renewed_in_Portal K3 1o.Be-Renewed _in_Portal & License_Server_Oulput

T Custo.. & HostiD1  HostiD2  HostID3  Entitem.. ProductlD Product.. Total Renewed  Remainl.  Expiration
TEST COM...[0011B832. | ' 1234567990 MSA0IUPRM Xpress Dat.. 1 1 o |3D1£201 0
TEST COM.. [0011BB22.. | ' |9999999908 MEITTUPRMME AVE SE |7 [t b 1310172010

T3l TEST Com. 00116822, ' 8559555995 M5921 UPRM|ME AVE i 1 [ o 13140172010
TEST COM... [00CDEGEE,..| ' |9999999908 ME921 UPRMME AVE 51 |4 4 o 1310172010

Statud TEST COM... DOCDEGES... : |3999909998 |NSA2TUPRMME AVE 54 . & 4 [4 13140172010
TEST COM... |[00CDBEEE. | |0599009990 MZ2ITEST |Analoges . |20 10 [10 30113010
TEST COM... |00AA3333. | ' |2220001111 |M5202UPRMXpress Dat.. | [ o FU0A010
TEST COM... (00843333, | ' [2230002272 | M592TUPRMME AVE S£ |2 2 o (30172010
TEST COM... [00AA3333. | ' |223000222% |M5921 UPRM|ME AVE 51 i I o 30010
TEST COM...|00AASSSS._ | f |2230002222|MZI2TEST [Testlicense || I o 30112010
Status: READY [ | 3:36 PM

How to save resulting files

The License Renewal Comparison Tool displays the result of the comparison process in several
tabs, for example the Matched tab. You can save each tab in a .csv spreadsheet file.

About this task

Saving the comparison results allows you to view the .csv files in a spreadsheet software like MS
Excel.

Before you begin

The Comparison Tool must be running and must have completed the comparison at least once.
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Procedure

1. To save the contents of a tab, click the tab to bring it to the foreground.
2. Click Save As....

A save dialog opens. Default location is your home directory. Default file name is the

name of the tab plus the current date and time: Naneyynmrddhhnm csv, for example
Matched200901210915.csv

3. To accept the default location and file name click Save.

Results

The result file is saved and ready to be opened in a spreadsheet software.

Example

A | B | C | D | E
1 |License Server(s) MN5802UPEM N5321UPRM N5322UPRM Entitlement
~ 2 |0011BB222222
3| 1 1234567890
4 1 1 99999999599
_ 5 |Totals 1 1 1
6 |00AA33333333
T ] 1 2220001111
8 1 2 2230002222
9 |Totals 1 1 2
n

How to view and save the
log file

The License Renewal Comparison Tool provides a log file which lists all files you loaded and any
issues during the comparison process.
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About this task

Checking the log file will give you confidence that the comparison process ran successfully without
errors. In case of errors you can review the log file for information. This file may also be requested
by Advantest support personnel to debug any tool issues.

Before you begin

The Comparison Tool must be running and must have completed the comparison at least once.

Procedure

1. To view the log file click Help > Show Log. A dialog window displays the log file.
2. To save the log file click Save As....
The default location is your home directory. The default file name is Renewallog.txt .

Example

Your log file may look as follows:

Tuesday, October 21, 2008 - 11:33 AM
>>>> Logging Started <<<<

Tuesday, October 21, 2008 - 11:33 AM
V93000 License Renewal Utility, Version 2009 (build 20080805.2211)

Tuesday, October 21, 2008 - 11:33 AM
Copyright(c) 2008, 2009 Verigy Limited, Verigy US Incorporated, All Rights Reserved.

Tuesday, October 21, 2008 - 11:33 AM
Loaded Verigy Products with Features File: products with features.csv

Tuesday, October 21, 2008 - 11:34 AM
Loaded Portal License Renewal Export File: Renewed name-date.csv

Tuesday, October 21, 2008 - 11:34 AM
Loaded Portal To-Be-Renewed License Export File: To-Be-Renewed name-date.csv

Tuesday, October 21, 2008 - 11:35 AM



Loaded Server Inventory File: license-inventory-server0l.txt
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